Default networking service in Solaris 11 is
network/physical:default
# svcprop network/physical:default|grep -i active_ncp
gives us the defaultfixed which defines type of installation
dladm command is used in PHYSICAL and DATA LINK layers
ipadm command is used in NETWORK layer
commands to find the network-ports
#dladm show-phys
default naming convention for the network cards are renamed as "NET0,1,2,3"
# dladm show-phys -m
this would show you the MAC address
# dladm show-link
network ports which are plumbed
Plumbing the network card
#ipadm create-ip net1
Assigning IP Address
#ipadm show-addr (lists the current IP's configured)
#ipadm create-addr -T static -a 192.168.0.150/24 net1
-T type of network
-a Address
-t to assign temporary IP address
To add a tag for easy identification for which virtual ip is assigned for which purpose as below.
#ipadm create-addr -T static -a 192.168.0.151/24 net1/apache1
/etc/ipadm/ipadm.conf (this is the file which holds the information of all the ip's)
Command to change the hostname
#svcs identity/node
#svcprop identity/node|grep nodename
#svccfg -s identity/node setprop config/nodename=<desired hostname>
#svcadm refresh identity/nodename
To change the DNS client entries..
#svcs dns/client
#svcprop dns/client |grep nameserver
#svccfg -s dns/cleint setprop config/nameserver=<desired DNS Server name>
To see the IP properties
#ipadm show-ifprop net1
for IPMP
#ipadm set-ifprop -p standby=on -m ip net1
To change the MTU value
#ipadm set-ifprop -p mtu=1400 -m ipv4 net1
To enable forwarding for all the NIC's
#ipadm set-prop -p forwarding=on ipv4
To enable the MTU value as jumbo frames (MTU value to 9000) this is possible only in the link layer..
#dladm show-linkprop -p mtu net1
Note: To do above operation you have to unplumb the interface
To create Virtual NIC
#dladm create-vnic -l net1 vnic0
#dladm set-linkprop -p maxbw=100m vnic0
#dladm show-vnic (Gives the details of all VNICS)
firewall rules are applicable to VNIC's which was not possible in SOLARIS 10.
Network Virtualization
dladm show-vnic
dladm create-etherstub stub0
dladm show-etherstub
dladm create-vnic -l vnic0 stub0
dladm create-vnic -l vnic1 stub0
dladm create-vnic -l vnic2 stub0
dladm show-vnic
network/physical:default
# svcprop network/physical:default|grep -i active_ncp
gives us the defaultfixed which defines type of installation
dladm command is used in PHYSICAL and DATA LINK layers
ipadm command is used in NETWORK layer
commands to find the network-ports
#dladm show-phys
default naming convention for the network cards are renamed as "NET0,1,2,3"
# dladm show-phys -m
this would show you the MAC address
# dladm show-link
network ports which are plumbed
Plumbing the network card
#ipadm create-ip net1
Assigning IP Address
#ipadm show-addr (lists the current IP's configured)
#ipadm create-addr -T static -a 192.168.0.150/24 net1
-T type of network
-a Address
-t to assign temporary IP address
To add a tag for easy identification for which virtual ip is assigned for which purpose as below.
#ipadm create-addr -T static -a 192.168.0.151/24 net1/apache1
/etc/ipadm/ipadm.conf (this is the file which holds the information of all the ip's)
Command to change the hostname
#svcs identity/node
#svcprop identity/node|grep nodename
#svccfg -s identity/node setprop config/nodename=<desired hostname>
#svcadm refresh identity/nodename
To change the DNS client entries..
#svcs dns/client
#svcprop dns/client |grep nameserver
#svccfg -s dns/cleint setprop config/nameserver=<desired DNS Server name>
To see the IP properties
#ipadm show-ifprop net1
for IPMP
#ipadm set-ifprop -p standby=on -m ip net1
To change the MTU value
#ipadm set-ifprop -p mtu=1400 -m ipv4 net1
To enable forwarding for all the NIC's
#ipadm set-prop -p forwarding=on ipv4
To enable the MTU value as jumbo frames (MTU value to 9000) this is possible only in the link layer..
#dladm show-linkprop -p mtu net1
Note: To do above operation you have to unplumb the interface
To create Virtual NIC
#dladm create-vnic -l net1 vnic0
#dladm set-linkprop -p maxbw=100m vnic0
#dladm show-vnic (Gives the details of all VNICS)
firewall rules are applicable to VNIC's which was not possible in SOLARIS 10.
Network Virtualization
dladm show-vnic
dladm create-etherstub stub0
dladm show-etherstub
dladm create-vnic -l vnic0 stub0
dladm create-vnic -l vnic1 stub0
dladm create-vnic -l vnic2 stub0
dladm show-vnic
No comments:
Post a Comment